Excel Integrations Experiencing Issues

Incident Report for Mailparser

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 15:24 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 24, 2026 - 15:16 EDT

Investigating

We are currently investigating an issue affecting Excel integrations

Our team is actively working to resolve the issue and we will provide updates as more information becomes available.
Posted Jul 24, 2026 - 14:57 EDT
This incident affected: Webhooks.